VMware Workstation 10.x < 10.0.5 Multiple Vulnerabilities (VMSA-2015-0001) (Linux)

Medium Nessus Plugin ID 81186


The remote host contains a virtualization application that is affected by multiple vulnerabilities.


The version of VMware Workstation installed on the remote host is version 10.x prior to 10.0.5. It is, therefore, affected by the following vulnerabilities :

- An unspecified flaw exists that allows a local attacker to escalate privileges or cause a denial of service via an arbitrary write to a file. (CVE-2014-8370)

- An input validation error exists in the Host Guest File System (HGFS) that allows a local attacker to cause a denial of service of the guest operating system.

- An input validation error exists in the VMware Authorization process (vmware-authd) that allows a remote attacker to cause a denial of service of the host operating system. (CVE-2015-1044)


Upgrade to VMware Workstation 10.0.5 or later.

See Also



Plugin Details

Severity: Medium

ID: 81186

File Name: vmware_workstation_linux_vmsa_2015_0001.nasl

Version: $Revision: 1.5 $

Type: local

Family: General

Published: 2015/02/05

Modified: 2015/06/21

Dependencies: 71053

Risk Information

Risk Factor: Medium


Base Score: 6.4

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:vmware:workstation

Required KB Items: Host/VMware Workstation/Version

Excluded KB Items: SMB/Registry/Enumerated

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2015/01/27

Vulnerability Publication Date: 2015/01/27

Reference Information

CVE: CVE-2014-8370, CVE-2015-1043, CVE-2015-1044

BID: 72336, 72337, 72338

OSVDB: 117669, 117670, 117671

VMSA: 2015-0001