VMware Player 6.x < 6.0.5 Multiple Vulnerabilities (VMSA-2015-0001) (Linux)

Medium Nessus Plugin ID 81184


The remote host contains software that is affected by multiple vulnerabilities.


The version of VMware Player installed on the remote host is version 6.x prior to 6.0.5. It is, therefore, affected by the following vulnerabilities :

- An unspecified flaw exists that allows a local attacker to escalate privileges or cause a denial of service via an arbitrary write to a file. (CVE-2014-8370)

- An input validation error exists in the Host Guest File System (HGFS) that allows a local attacker to cause a denial of service of the guest operating system.

- An input validation error exists in the VMware Authorization process (vmware-authd) that allows a remote attacker to cause a denial of service of the host operating system. (CVE-2015-1044)


Upgrade to VMware Player 6.0.5 or later.

See Also



Plugin Details

Severity: Medium

ID: 81184

File Name: vmware_player_linux_vmsa_2015_0001.nasl

Version: 1.6

Type: local

Family: General

Published: 2015/02/05

Updated: 2018/08/06

Dependencies: 71051

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.4

Temporal Score: 4.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:vmware:player

Required KB Items: Host/VMware Player/Version

Excluded KB Items: SMB/Registry/Enumerated

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2015/01/27

Vulnerability Publication Date: 2015/01/27

Reference Information

CVE: CVE-2014-8370, CVE-2015-1043, CVE-2015-1044

BID: 72336, 72337, 72338

VMSA: 2015-0001