VMware Security Updates for vCenter Server (VMSA-2015-0001) (POODLE)
High Nessus Plugin ID 81146
SynopsisThe remote host has a virtualization management application installed that is affected by multiple security vulnerabilities.
DescriptionThe VMware vCenter Server installed on the remote host is version 5.5 prior to Update 2d. It is, therefore, affected by multiple vulnerabilities in the included OpenSSL library :
- An error exists related to DTLS SRTP extension handling and specially crafted handshake messages that can allow denial of service attacks via memory leaks.
- An error exists related to the way SSL 3.0 handles padding bytes when decrypting messages encrypted using block ciphers in cipher block chaining (CBC) mode.
Man-in-the-middle attackers can decrypt a selected byte of a cipher text in as few as 256 tries if they are able to force a victim application to repeatedly send the same data over newly created SSL 3.0 connections. This is also known as the 'POODLE' issue. (CVE-2014-3566)
- An error exists related to session ticket handling that can allow denial of service attacks via memory leaks.
- An error exists related to the build configuration process and the 'no-ssl3' build option that allows servers and clients to process insecure SSL 3.0 handshake messages. (CVE-2014-3568)
SolutionUpgrade to VMware vCenter Server 5.5u2d (5.5.0 build-2183111) or later.