McAfee ePolicy Orchestrator 4.x < 4.6.9 / 5.x < 5.1.2 Multiple Vulnerabilities (SB10095)

Medium Nessus Plugin ID 81106


A security management application installed on the remote host is affected by multiple vulnerabilities.


The version of McAfee ePolicy Orchestrator (ePO) installed on the remote Windows host is 4.x prior to 4.6.9 or 5.x prior to 5.1.2. It is, therefore, affected by multiple vulnerabilities :

- An XXE (XML External Entity) injection vulnerability exists in the Server Task Log due to an incorrectly configured XML parser accepting XML external entities from an untrusted source. A remote, authenticated attacker, by sending specially crafted XML data via the 'conditionXML' parameter, can gain access to arbitrary files. (CVE-2015-0921)

- An information disclosure vulnerability exists due to the use of a shared secret key to encrypt password information. A remote attacker with knowledge of the key can decrypt the administrator password. (CVE-2015-0922)


Upgrade to McAfee ePO version 4.6.9 / 5.1.2 or later, or apply the vendor-supplied workaround.

See Also

Plugin Details

Severity: Medium

ID: 81106

File Name: mcafee_epo_sb10095.nasl

Version: $Revision: 1.7 $

Type: local

Agent: windows

Family: Windows

Published: 2015/01/30

Modified: 2016/12/19

Dependencies: 67119

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mcafee:epolicy_orchestrator

Required KB Items: SMB/mcafee_epo/Path, SMB/mcafee_epo/ver

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2015/01/09

Vulnerability Publication Date: 2015/01/06

Reference Information

CVE: CVE-2015-0921, CVE-2015-0922

BID: 71881, 72298

OSVDB: 116855, 116930