ESXi 5.5 < Build 2352327 Multiple Vulnerabilities (remote check) (POODLE)

medium Nessus Plugin ID 81085
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote VMware ESXi 5.5 host is affected by multiple vulnerabilities.

Description

The remote VMware ESXi host is version 5.5 prior to build 2352327. It is, therefore, affected by the following vulnerabilities :

- An error exists related to DTLS SRTP extension handling and specially crafted handshake messages that can allow denial of service attacks via memory leaks.
(CVE-2014-3513)

- An error exists related to the way SSL 3.0 handles padding bytes when decrypting messages encrypted using block ciphers in cipher block chaining (CBC) mode. A man-in-the-middle attacker can decrypt a selected byte of a cipher text in as few as 256 tries if they are able to force a victim application to repeatedly send the same data over newly created SSL 3.0 connections. This is also known as the 'POODLE' issue. (CVE-2014-3566)

- An error exists related to session ticket handling that can allow denial of service attacks via memory leaks.
(CVE-2014-3567)

- An error exists related to the build configuration process and the 'no-ssl3' build option that allows servers and clients to process insecure SSL 3.0 handshake messages. (CVE-2014-3568)

- A denial of service vulnerability in libxml2 due to entity expansion even when entity substitution is disabled. A remote attacker, using a crafted XML document containing larger number of nested entity references, can cause the consumption of CPU resources.
(CVE-2014-3660)

- An unspecified privilege escalation vulnerability.
(CVE-2014-8370)

- An unspecified denial of service vulnerability due to an input validation issue in the VMware Authorization process (vmware-authd). (CVE-2015-1044)

Solution

Apply patch ESXi550-201403102-SG and ESXi550-201501101-SG for ESXi 5.5.

See Also

https://www.vmware.com/security/advisories/VMSA-2015-0001.html

https://www.imperialviolet.org/2014/10/14/poodle.html

https://www.openssl.org/~bodo/ssl-poodle.pdf

https://tools.ietf.org/html/draft-ietf-tls-downgrade-scsv-00

Plugin Details

Severity: Medium

ID: 81085

File Name: vmware_esxi_5_5_build_2352327_remote.nasl

Version: 1.10

Type: remote

Family: Misc.

Published: 1/29/2015

Updated: 11/25/2019

Dependencies: vmware_vsphere_detect.nbin

Risk Information

CVSS Score Source: CVE-2014-8370

VPR

Risk Factor: Medium

Score: 6.1

CVSS v2

Risk Factor: Medium

Base Score: 6.4

Temporal Score: 4.7

Vector: AV:N/AC:L/Au:N/C:N/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/o:vmware:esxi

Required KB Items: Host/VMware/version, Host/VMware/release

Exploit Ease: No known exploits are available

Patch Publication Date: 1/27/2015

Vulnerability Publication Date: 1/27/2015

Reference Information

CVE: CVE-2014-3513, CVE-2014-3566, CVE-2014-3567, CVE-2014-3568, CVE-2014-3660, CVE-2014-8370, CVE-2015-1044

BID: 70574, 70584, 70585, 70586, 70644, 72336, 72338

CERT: 577193

VMSA: 2015-0001