Mac OS X : Apple Safari < 6.2.3 / 7.1.3 / 8.0.3 Multiple Vulnerabilities

Medium Nessus Plugin ID 81051


The remote host contains a web browser that is affected by multiple vulnerabilities.


The version of Apple Safari installed on the remote Mac OS X host is prior to 6.2.3 / 7.1.3 / 8.0.3. It is, therefore, affected by multiple memory corruption issues in WebKit. A remote attacker, using a specially crafted website, can exploit these to execute arbitrary code.


Upgrade to Apple Safari 6.2.3 / 7.1.3 / 8.0.3 or later.

See Also

Plugin Details

Severity: Medium

ID: 81051

File Name: macosx_Safari8_0_3.nasl

Version: $Revision: 1.5 $

Type: local

Agent: macosx

Published: 2015/01/28

Modified: 2016/05/17

Dependencies: 31604

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:ND/RC:ND

Vulnerability Information

CPE: cpe:/a:apple:safari

Required KB Items: Host/local_checks_enabled, Host/MacOSX/Version, MacOSX/Safari/Installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/01/27

Vulnerability Publication Date: 2014/09/19

Reference Information

CVE: CVE-2014-3192, CVE-2014-4476, CVE-2014-4477, CVE-2014-4479

BID: 70273, 72329, 72330, 72331

OSVDB: 112753, 117622, 117623, 117624

APPLE-SA: APPLE-SA-2015-01-27-3