Honeywell OPOS Suite Stack Buffer Overflow

Medium Nessus Plugin ID 80910


The remote host is vulnerable to multiple stack-based buffer overflow vulnerabilities.


The Honeywell OPOS Suite installed on the remote host is prior to version It is, therefore, affected by stack-based buffer overflow vulnerabilities in the bundled 'HWOPOSScale.ocx' and 'HWOPOSSCANNER.ocx' ActiveX controls, due to a failure to check the length of user-supplied input to the Open method. A remote attacker, using a specially crafted web page, can exploit these to execute arbitrary code.


Upgrade to product version or later.

See Also

Plugin Details

Severity: Medium

ID: 80910

File Name: scada_honeywell_opos_hwoposscanner_activex.nbin

Version: $Revision: 1.108 $

Type: local

Family: SCADA

Published: 2015/01/22

Modified: 2018/03/21

Dependencies: 13855

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: cpe:/a:honeywell:opos_suite

Required KB Items: SMB/Registry/Enumerated

Patch Publication Date: 2014/12/11

Vulnerability Publication Date: 2014/12/11

Reference Information

CVE: CVE-2014-8269

BID: 71642

OSVDB: 115784, 115785

CERT: 659684