LibreOffice < 4.2.8 / 4.3.5 RTF File Handling Code Execution (Mac OS X)

Medium Nessus Plugin ID 80830


The remote host contains an application that is affected by an invalid memory write vulnerability.


The version of LibreOffice installed on the remote Mac OS X host is prior to 4.2.8 or 4.3.x prior to 4.3.5. It is, therefore, affected by an invalid memory write vulnerability. An attacker, using a specially crafted Rich Text Format (RTF) file, can exploit this to cause a denial of service or possibly execute arbitrary code.

Note that Nessus has not attempted to exploit this issue but has instead relied only on the application's self-reported version number.


Upgrade to LibreOffice version 4.2.8 (, 4.3.5 ( or later.

See Also

Plugin Details

Severity: Medium

ID: 80830

File Name: macosx_libreoffice_435.nasl

Version: $Revision: 1.3 $

Type: local

Agent: macosx

Published: 2015/01/19

Modified: 2016/11/28

Dependencies: 55575

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:libreoffice:libreoffice

Required KB Items: installed_sw/LibreOffice, Host/MacOSX/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/12/18

Vulnerability Publication Date: 2014/11/19

Reference Information

CVE: CVE-2014-9093

BID: 71313

OSVDB: 115069