Flash Player For Mac <= 16.0.0.235 Multiple Vulnerabilities (APSB15-01)

Critical Nessus Plugin ID 80487

Synopsis

The remote Mac OS X host has a browser plugin that is affected by multiple vulnerabilities.

Description

According to its version, the installation of Adobe Flash Player installed on the remote Mac OS X host is equal or prior to 16.0.0.235.
It is, therefore, affected by the following vulnerabilities :

- An unspecified improper file validation issue.
(CVE-2015-0301)

- An unspecified information disclosure vulnerability, which can be exploited to capture keystrokes.
(CVE-2015-0302)

- Multiple memory corruption vulnerabilities allow an attacker to execute arbitrary code. (CVE-2015-0303, CVE-2015-0306)

- Multiple heap-based buffer overflow vulnerabilities that can be exploited to execute arbitrary code.
(CVE-2015-0304, CVE-2015-0309)

- An unspecified type confusion vulnerability that can lead to code execution. (CVE-2015-0305)

- An out-of-bounds read vulnerability that can be exploited to leak memory addresses. (CVE-2015-0307)

- A use-after-free vulnerability that results in arbitrary code execution. (CVE-2015-0308)

Solution

Upgrade to Adobe Flash Player version 16.0.0.257 or later.

Alternatively, Adobe has made version 13.0.0.260 available for those installations that cannot be upgraded to 16.x.

See Also

https://helpx.adobe.com/security/products/flash-player/apsb15-01.html

http://www.nessus.org/u?0cb17c10

Plugin Details

Severity: Critical

ID: 80487

File Name: macosx_flash_player_16_0_0_257.nasl

Version: 1.9

Type: local

Agent: macosx

Published: 2015/01/13

Updated: 2019/11/25

Dependencies: 53914

Risk Information

Risk Factor: Critical

CVSS Score Source: CVE-2015-0309

CVSS v2.0

Base Score: 10

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Required KB Items: MacOSX/Flash_Player/Version

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2015/01/13

Vulnerability Publication Date: 2015/01/13

Reference Information

CVE: CVE-2015-0301, CVE-2015-0302, CVE-2015-0303, CVE-2015-0304, CVE-2015-0305, CVE-2015-0306, CVE-2015-0307, CVE-2015-0308, CVE-2015-0309

BID: 72031, 72032, 72033, 72034, 72035, 72036, 72037, 72038, 72039