GLSA-201412-51 : Asterisk: Multiple vulnerabilities

High Nessus Plugin ID 80272


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201412-51 (Asterisk: Multiple vulnerabilities)

Multiple unspecified vulnerabilities have been discovered in Asterisk.
Please review the CVE identifiers referenced below for details.
Impact :

Unauthenticated remote attackers can cause Denial of Service or bypass intended ACL restrictions. Authenticated remote attackers can gain escalated privileges.
Workaround :

There is no known workaround at this time.


All asterisk users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-misc/asterisk-11.14.2'

See Also

Plugin Details

Severity: High

ID: 80272

File Name: gentoo_GLSA-201412-51.nasl

Version: $Revision: 1.3 $

Type: local

Published: 2014/12/29

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9

Temporal Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:asterisk, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/12/28

Reference Information

CVE: CVE-2014-8412, CVE-2014-8414, CVE-2014-8417, CVE-2014-8418, CVE-2014-9374

BID: 71218, 71222, 71227, 71228, 71607

GLSA: 201412-51