APPLE-SA-2014-12-22-1 OS X NTP Security Update (Mac OS X)

High Nessus Plugin ID 80227

Synopsis

The remote host is missing a security update.

Description

The remote Mac OS X host contains a version of the NTP daemon that is affected by multiple stack-based buffer overflow vulnerabilities that can allow remote arbitrary code execution.

Solution

Install the vendor-supplied security patch for APPLE-SA-2014-12-22-1.

See Also

https://support.apple.com/en-us/HT6601

http://www.nessus.org/u?90b0a302

Plugin Details

Severity: High

ID: 80227

File Name: macosx_SecUpd_ntp.nbin

Version: $Revision: 1.179 $

Type: local

Agent: macosx

Published: 2014/12/24

Modified: 2018/07/13

Dependencies: 12634

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: cpe:/o:apple:mac_os_x, cpe:/a:ntp:ntp

Required KB Items: Host/local_checks_enabled, Host/MacOSX/Version

Patch Publication Date: 2014/12/22

Vulnerability Publication Date: 2014/12/19

Reference Information

CVE: CVE-2014-9295

BID: 71761

CERT: 852879

APPLE-SA: APPLE-SA-2014-12-22-1