GLSA-201412-32 : sendmail: Information disclosure

Low Nessus Plugin ID 80209


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201412-32 (sendmail: Information disclosure)

The sm_close_on_exec function in conf.c has arguments in the wrong order.
Impact :

A local attacker could get access to unintended high-numbered file descriptors via a specially crafted program.
Workaround :

There is no known workaround at this time.


All sendmail users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=mail-mta/sendmail-8.14.9'

See Also

Plugin Details

Severity: Low

ID: 80209

File Name: gentoo_GLSA-201412-32.nasl

Version: $Revision: 1.3 $

Type: local

Published: 2014/12/23

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Low


Base Score: 1.9

Temporal Score: 1.7

Vector: CVSS2#AV:L/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:sendmail, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/12/22

Reference Information

CVE: CVE-2014-3956

BID: 67791

GLSA: 201412-32