LibreOffice 4.x < 4.2.6-secfix ( Multiple Vulnerabilities

High Nessus Plugin ID 80078


The remote host contains an application that is affected by multiple vulnerabilities.


A version of LibreOffice is installed on the remote Windows host that is 4.x prior to 4.2.6-secfix ( It is, therefore, affected by the following vulnerabilities :

- An input-validation error exists related to handling Calc spreadsheets that allows arbitrary command execution. (CVE-2014-3524)

- An input-validation error exists related to 'Update Links' prompt handling that allows information disclosure via improperly included OLE2 previews.

Note that Nessus has not attempted to exploit these issues but has instead relied only on the application's self-reported version number.


Upgrade to LibreOffice version 4.2.6-secfix ( or later.

See Also

Plugin Details

Severity: High

ID: 80078

File Name: libreoffice_4263.nasl

Version: $Revision: 1.8 $

Type: local

Agent: windows

Family: Windows

Published: 2014/12/17

Modified: 2016/11/23

Dependencies: 55573

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:libreoffice:libreoffice

Required KB Items: installed_sw/LibreOffice

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/08/28

Vulnerability Publication Date: 2014/08/21

Reference Information

CVE: CVE-2014-3524, CVE-2014-3575

BID: 69351, 69354

OSVDB: 110266, 110267