ESXi 5.1 < Build 2323231 glibc Library Multiple Vulnerabilities (remote check)

medium Nessus Plugin ID 80037
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote VMware ESXi 5.1 host is affected by multiple vulnerabilities.

Description

The remote VMware ESXi host is version 5.1 prior to build 2323231. It is, therefore, affected by the following vulnerabilities in the glibc library :

- A buffer overflow flaw exists in the 'extend_buffers' function of the 'posix/regexec.c' file due to improper validation of user input. Using a specially crafted expression, a remote attacker can cause a denial of service. (CVE-2013-0242)

- A buffer overflow flaw exists in the 'getaddrinfo' function of the '/sysdeps/posix/getaddrinfo.c' file due to improper validation of user input. A remote attacker can cause a denial of service by triggering a large number of domain conversions. (CVE-2013-1914)

Solution

Apply patch ESXi510-201412101-SG for ESXi 5.1.

See Also

https://www.vmware.com/security/advisories/VMSA-2014-0008.html

Plugin Details

Severity: Medium

ID: 80037

File Name: vmware_esxi_5_1_build_2323231_remote.nasl

Version: 1.6

Type: remote

Family: Misc.

Published: 12/15/2014

Updated: 11/15/2018

Dependencies: vmware_vsphere_detect.nbin

Risk Information

VPR

Risk Factor: Medium

Score: 4.4

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/o:vmware:esxi

Required KB Items: Host/VMware/version, Host/VMware/release

Exploit Ease: No known exploits are available

Patch Publication Date: 12/4/2014

Vulnerability Publication Date: 1/29/2013

Reference Information

CVE: CVE-2013-0242, CVE-2013-1914

BID: 57638, 58839

VMSA: 2014-0008