Mandriva Linux Security Advisory : mediawiki (MDVSA-2014:241)

High Nessus Plugin ID 79986


The remote Mandriva Linux host is missing one or more security updates.


Updated mediawiki packages fix security vulnerabilies :

In MediaWiki before 1.23.7, a missing CSRF check could allow reflected XSS on wikis that allow raw HTML (CVE-2014-9276).

MediaWiki's mangling, in MediaWiki before 1.23.7, could allow an article editor to inject code into API consumers that blindly unserialize PHP representations of the page from the API (CVE-2014-9277).

This update provides MediaWiki 1.23.7, which fixes these security issues and other bugs.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 79986

File Name: mandriva_MDVSA-2014-241.nasl

Version: $Revision: 1.3 $

Type: local

Published: 2014/12/15

Modified: 2015/01/07

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:mediawiki, p-cpe:/a:mandriva:linux:mediawiki-mysql, p-cpe:/a:mandriva:linux:mediawiki-pgsql, p-cpe:/a:mandriva:linux:mediawiki-sqlite, cpe:/o:mandriva:business_server:1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/12/14

Reference Information

CVE: CVE-2014-9276, CVE-2014-9277

BID: 71473

MDVSA: 2014:241