VMware vCenter Server Appliance Unspecified XSS (VMSA-2014-0012)

medium Nessus Plugin ID 79863
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote host has a virtualization appliance installed that is affected by a cross-site scripting vulnerability.


The version of VMware vCenter Server Appliance installed on the remote host is 5.1 prior to Update 3. It is, therefore, affected by an unspecified cross-site scripting vulnerability. A remote attacker can exploit this by means of a specially crafted URL or malicious web page, which can result in the execution of arbitrary script code.


Upgrade to VMware vCenter Server Appliance 5.1 Update 3 or later.

See Also


Plugin Details

Severity: Medium

ID: 79863

File Name: vmware_vcenter_server_appliance_vmsa-2014-0012.nasl

Version: 1.9

Type: local

Family: Misc.

Published: 12/12/2014

Updated: 9/26/2019

Dependencies: ssh_get_info.nasl

Risk Information


Risk Factor: Low

Score: 3


Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:vmware:vcenter_server_appliance

Required KB Items: Host/VMware vCenter Server Appliance/Version, Host/VMware vCenter Server Appliance/Build

Exploit Ease: No known exploits are available

Patch Publication Date: 12/4/2014

Vulnerability Publication Date: 12/4/2014

Reference Information

CVE: CVE-2014-3797

BID: 71492

VMSA: 2014-0012

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990