GLSA-201412-03 : Dovecot: Denial of Service

Medium Nessus Plugin ID 79813

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-201412-03 (Dovecot: Denial of Service)

Dovecot does not properly close connections, allowing a resource exhaustion for incomplete SSL/TLS handshakes.
Impact :

A remote attacker could possibly cause a Denial of Service condition.
Workaround :

There is no known workaround at this time.

Solution

All Dovecot users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-mail/dovecot-2.2.13'

See Also

https://security.gentoo.org/glsa/201412-03

Plugin Details

Severity: Medium

ID: 79813

File Name: gentoo_GLSA-201412-03.nasl

Version: 1.4

Type: local

Published: 2014/12/09

Updated: 2018/12/05

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:dovecot, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/12/08

Reference Information

CVE: CVE-2014-3430

BID: 67306

GLSA: 201412-03