HP Network Node Manager i (NNMi) 8.x / 9.0x / 9.1x / 9.20 Unspecified XSS

Medium Nessus Plugin ID 79798


The remote web server hosts an application that is affected by a cross- site scripting vulnerability.


According to its version number, the web interface for HP Network Node Manager i (NNMi) installed on the remote host is affected by an unspecified cross-site scripting vulnerability.


For HP Network Node Manager i (NNMi) 9.0x, 9.1x, and 9.20 apply the appropriate hotfix provided by the vendor. For NNMi 8.x, first upgrade to one of those versions and then apply the appropriate hotfix.
Alternatively, upgrade to version 9.21 or later.

See Also


Plugin Details

Severity: Medium

ID: 79798

File Name: hp_nnmi_HPSBMU02798-rhel.nasl

Version: $Revision: 1.3 $

Type: local

Agent: unix

Published: 2014/12/08

Modified: 2015/02/03

Dependencies: 79802

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:hp:network_node_manager_i

Required KB Items: Settings/ParanoidReport, installed_sw/HP Network Node Manager i, Host/RedHat/release, Host/cpu

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/08/02

Vulnerability Publication Date: 2012/08/02

Reference Information

CVE: CVE-2012-2022

BID: 54815

OSVDB: 84459

HP: HPSBMU02798, SSRT100908, emr_na-c03405705

IAVB: 2012-B-0074

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990