Oracle Linux 6 / 7 : docker (ELSA-2014-3095)

High Nessus Plugin ID 79758


The remote Oracle Linux host is missing one or more security updates.


Description of changes:

- Rename requirement of docker-io-pkg-devel in %package devel as docker-pkg-devel
- Rename as docker
- Restore SysV init scripts for Oracle Linux 6

- Update source to 1.3.2 from Prevent host privilege escalation from an image extraction vulnerability (CVE-2014-6407).
Prevent container escalation from malicious security options applied to images (CVE-2014-6408).
The `--insecure-registry` flag of the `docker run` command has undergone several refinements and additions.
You can now specify a sub-net in order to set a range of registries which the Docker daemon will consider insecure.
By default, Docker now defines `localhost` as an insecure registry.
Registries can now be referenced using the Classless Inter-Domain Routing (CIDR) format.
When mirroring is enabled, the experimental registry v2 API is skipped.

- Remove pandoc from build reqs

- update to v1.3.1

- Resolves: rhbz#1153936 - update to v1.3.0
- don't install zsh files
- iptables=false => ip-masq=false

- Resolves: rhbz#1149882 - systemd unit and socket file updates

- Resolves: rhbz#1139415 - correct path for bash completion /usr/share/bash-completion/completions
- versioned provides for docker
- golang versioned requirements for devel and pkg-devel
- remove macros from changelog
- don't own dirs owned by vim, systemd, bash

- Resolves: rhbz#1145660 - support /etc/sysconfig/docker-storage From: Colin Walters <<A HREF=''>walters at</A>>
- patch to ignore selinux if it's disabled From: Dan Walsh <<A HREF=''>dwalsh at</A>>

- Provides docker only for f21 and above

- Resolves: rhbz#1132824 - update to v1.2.0


Update the affected docker packages.

See Also

Plugin Details

Severity: High

ID: 79758

File Name: oraclelinux_ELSA-2014-3095.nasl

Version: $Revision: 1.5 $

Type: local

Agent: unix

Published: 2014/12/06

Modified: 2015/12/01

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:oracle:linux:docker, p-cpe:/a:oracle:linux:docker-devel, p-cpe:/a:oracle:linux:docker-pkg-devel, cpe:/o:oracle:linux:6, cpe:/o:oracle:linux:7

Required KB Items: Host/local_checks_enabled, Host/OracleLinux, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 2014/12/05

Reference Information

CVE: CVE-2014-6407, CVE-2014-6408