Debian DSA-3089-1 : jasper - security update

high Nessus Plugin ID 79730

Synopsis

The remote Debian host is missing a security-related update.

Description

Jose Duart of the Google Security Team discovered heap-based buffer overflow flaws in JasPer, a library for manipulating JPEG-2000 files, which could lead to denial of service (application crash) or the execution of arbitrary code.

Solution

Upgrade the jasper packages.

For the stable distribution (wheezy), these problems have been fixed in version 1.900.1-13+deb7u1.

For the upcoming stable distribution (jessie) and the unstable distribution (sid), these problems will be fixed soon.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=772036

https://packages.debian.org/source/wheezy/jasper

https://www.debian.org/security/2014/dsa-3089

Plugin Details

Severity: High

ID: 79730

File Name: debian_DSA-3089.nasl

Version: 1.12

Type: local

Agent: unix

Published: 12/5/2014

Updated: 1/11/2021

Supported Sensors: Frictionless Assessment Agent, Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:jasper, cpe:/o:debian:debian_linux:7.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 12/4/2014

Reference Information

CVE: CVE-2014-9029

DSA: 3089