Splunk Enterprise 6.0.x < 6.0.7 Multiple Vulnerabilities (POODLE)

Medium Nessus Plugin ID 79723


The remote web server contains an application that is affected by multiple vulnerabilities.


According to its version number, the Splunk Enterprise hosted on the remote web server is 6.0.x prior to 6.0.7. It is, therefore, affected by the following vulnerabilities :

- A man-in-the-middle (MitM) information disclosure vulnerability, known as POODLE, exists due to the way SSL 3.0 handles padding bytes when decrypting messages encrypted using block ciphers in cipher block chaining (CBC) mode. A MitM attacker can decrypt a selected byte of a cipher text in as few as 256 tries if they are able to force a victim application to repeatedly send the same data over newly created SSL 3.0 connections.

- A flaw exists in the included OpenSSL library due to handling session tickets that have not been properly verified for integrity. A remote attacker, by using a large number of invalid session tickets, can exploit this to cause a denial of service. (CVE-2014-3567)

- A cross-site scripting flaw exists within the Dashboard due to improperly validating input. This allows a remote attacker, using a specially crafted request, to execute arbitrary script code in the user's browser session within the trust relationship. (CVE-2014-5466)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Splunk Enterprise 6.0.7 or later.

See Also





Plugin Details

Severity: Medium

ID: 79723

File Name: splunk_607.nasl

Version: 1.15

Type: remote

Family: CGI abuses

Published: 2014/12/04

Updated: 2019/11/25

Dependencies: 47619, 49069

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2014-5466

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:splunk:splunk

Required KB Items: installed_sw/Splunk

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2014/11/19

Vulnerability Publication Date: 2014/10/14

Reference Information

CVE: CVE-2014-3566, CVE-2014-3567, CVE-2014-5466

BID: 70574, 70586, 71257

CERT: 577193

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990