Splunk Enterprise 6.0.x < 6.0.6 Multiple Vulnerabilities

medium Nessus Plugin ID 79722


The remote web server contains an application that is affected by multiple vulnerabilities.


According to its version number, the Splunk Enterprise hosted on the remote web server is 6.0.x prior to 6.0.6. It is, therefore, affected by the following vulnerabilities :

- The included OpenSSL library contains a TLS downgrade weakness. By using fragmented ClientHello messages, a remote, man-in-the-middle attacker can force a downgrade to TLS 1.0. (CVE-2014-3511)

- A cross-site scripting vulnerability exists due to improper validation of user-supplied input when parsing events. This allows a remote attacker, using a specially crafted request, to execute arbitrary script code in the user's browser session within the trust relationship.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Splunk Enterprise 6.0.6 or later.

See Also


Plugin Details

Severity: Medium

ID: 79722

File Name: splunk_606.nasl

Version: 1.10

Type: remote

Family: CGI abuses

Published: 12/4/2014

Updated: 1/19/2021

Risk Information


Risk Factor: Low

Score: 3


Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:splunk:splunk

Required KB Items: installed_sw/Splunk

Exploit Ease: No exploit is required

Patch Publication Date: 9/30/2014

Vulnerability Publication Date: 8/6/2014

Reference Information

CVE: CVE-2014-3511, CVE-2014-8303

BID: 69079

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990