Splunk Enterprise 5.0.x < 5.0.11 Multiple Vulnerabilities (POODLE)

High Nessus Plugin ID 79721


The remote web server contains an application that is affected by multiple vulnerabilities.


According to its version number, the Splunk Enterprise hosted on the remote web server is 5.0.x prior to 5.0.11. It is, therefore, affected by the following vulnerabilities :

- A man-in-the-middle (MitM) information disclosure vulnerability, known as POODLE, exists due to the way SSL 3.0 handles padding bytes when decrypting messages encrypted using block ciphers in cipher block chaining (CBC) mode. A MitM attacker can decrypt a selected byte of a cipher text in as few as 256 tries if they are able to force a victim application to repeatedly send the same data over newly created SSL 3.0 connections.

- A flaw exists in the included OpenSSL library due to handling session tickets that have not been properly verified for integrity. A remote attacker, by using a large number of invalid session tickets, can exploit this to cause a denial of service. (CVE-2014-3567)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Splunk Enterprise 5.0.11 or later.

See Also





Plugin Details

Severity: High

ID: 79721

File Name: splunk_5011.nasl

Version: $Revision: 1.11 $

Type: remote

Family: Web Servers

Published: 2014/12/04

Modified: 2016/05/12

Dependencies: 47619, 49069

Risk Information

Risk Factor: High


Base Score: 7.1

Temporal Score: 5.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:U/RL:TF/RC:UR

Vulnerability Information

CPE: cpe:/a:splunk:splunk

Required KB Items: installed_sw/Splunk

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/11/20

Vulnerability Publication Date: 2014/10/14

Reference Information

CVE: CVE-2014-3566, CVE-2014-3567

BID: 70574, 70586

OSVDB: 113251, 113374

CERT: 577193