CUPS < 2.0.1 SSLv3 Legacy Encryption Vulnerability (POODLE)

Medium Nessus Plugin ID 79580


The remote printer service is potentially affected by an information disclosure vulnerability.


According to its banner, the CUPS printer service installed on the remote host is a version prior to 2.0.1. It is, therefore, potentially affected by a man-in-the-middle (MitM) information disclosure vulnerability known as POODLE. The vulnerability is due to the way SSL 3.0 handles padding bytes when decrypting messages encrypted using block ciphers in cipher block chaining (CBC) mode. MitM attackers can decrypt a selected byte of a cipher text in as few as 256 tries if they are able to force a victim application to repeatedly send the same data over newly created SSL 3.0 connections.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Either upgrade to CUPS version 2.0.1 or later, or apply the vendor patch.

See Also

Plugin Details

Severity: Medium

ID: 79580

File Name: cups_2_0_1.nasl

Version: $Revision: 1.7 $

Type: remote

Family: Misc.

Published: 2014/11/26

Modified: 2016/05/24

Dependencies: 10107, 29727

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:U/RL:TF/RC:UR

Vulnerability Information

CPE: cpe:/a:apple:cups

Required KB Items: www/cups, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/11/14

Vulnerability Publication Date: 2014/10/14

Reference Information

CVE: CVE-2014-3566

BID: 70574

OSVDB: 113251

CERT: 577193