OracleVM 3.1 : kernel-uek (OVMSA-2013-0010)

Medium Nessus Plugin ID 79499


The remote OracleVM host is missing one or more security updates.


The remote OracleVM system is missing necessary patches to address critical security updates :

- xen-pciback: rate limit error messages from xen_pcibk_enable_msi[,x] (Jan Beulich) [Orabug:
16243736] (CVE-2013-0231)

- Xen: Fix stack corruption in xen_failsafe_callback for 32bit PVOPS guests. (Frediano Ziglio) [Orabug: 16274171] (CVE-2013-0190)

- netback: correct netbk_tx_err to handle wrap around.
(Ian Campbell) [Orabug: 16243309] (CVE-2013-0216 CVE-2013-0217)

- xen/netback: free already allocated memory on failure in xen_netbk_get_requests (Ian Campbell) [Orabug: 16243309] (CVE-2013-0216 CVE-2013-0217)

- xen/netback: don't leak pages on failure in xen_netbk_tx_check_gop. (Ian Campbell) [Orabug:
16243309] (CVE-2013-0216 CVE-2013-0217)

- xen/netback: shutdown the ring if it contains garbage.
(Ian Campbell) [Orabug: 16243309] (CVE-2013-0216 CVE-2013-0217)

- e1000e: Avoid wrong check on TX hang (Jeff Kirsher) [Orabug: 15834316]


Update the affected kernel-uek / kernel-uek-firmware packages.

See Also

Plugin Details

Severity: Medium

ID: 79499

File Name: oraclevm_OVMSA-2013-0010.nasl

Version: $Revision: 1.3 $

Type: local

Published: 2014/11/26

Modified: 2017/02/14

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5.2

Temporal Score: 4.5

Vector: CVSS2#AV:A/AC:M/Au:S/C:N/I:N/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:oracle:vm:kernel-uek, p-cpe:/a:oracle:vm:kernel-uek-firmware, cpe:/o:oracle:vm_server:3.1

Required KB Items: Host/local_checks_enabled, Host/OracleVM/release, Host/OracleVM/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/02/07

Reference Information

CVE: CVE-2013-0190, CVE-2013-0216, CVE-2013-0217, CVE-2013-0231

BID: 57433, 57740, 57743, 57744