WordPress < 3.7.5 / 3.8.5 / 3.9.3 / 4.0.1 Multiple Vulnerabilities

medium Nessus Plugin ID 79437

Synopsis

The remote web server contains a PHP application that is affected by multiple vulnerabilities.

Description

According to its version number, the WordPress application installed on the remote web server is affected by multiple vulnerabilities :

- Multiple unspecified errors exist that could allow cross-site scripting attacks.

- An unspecified error exists that could allow cross-site request forgery attacks.

- An error exists related to password handling that could allow denial of service attacks.

- An unspecified error exists that could allow server-side request forgery attacks.

- A hash collision error exists that could allow a user account to be compromised.

- An error exists related to password reset processing that could allow a user account to be compromised.

- An error exists related to the post or page comment field that could allow persistent cross-site scripting attacks.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to WordPress 3.7.5 / 3.8.5 / 3.9.3 / 4.0.1 or later.

See Also

https://wordpress.org/news/2014/11/wordpress-4-0-1/

https://codex.wordpress.org/Version_3.7.5

https://codex.wordpress.org/Version_3.8.5

https://codex.wordpress.org/Version_3.9.3

https://codex.wordpress.org/Version_4.0.1

Plugin Details

Severity: Medium

ID: 79437

File Name: wordpress_4_0_1.nasl

Version: 1.12

Type: remote

Family: CGI abuses

Published: 11/25/2014

Updated: 6/5/2024

Configuration: Enable paranoid mode

Supported Sensors: Nessus

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: cpe:/a:wordpress:wordpress

Required KB Items: installed_sw/WordPress, www/PHP, Settings/ParanoidReport

Excluded KB Items: Settings/disable_cgi_scanning

Exploit Available: true

Exploit Ease: No exploit is required

Patch Publication Date: 11/20/2014

Vulnerability Publication Date: 11/20/2014

Reference Information

CVE: CVE-2014-9031, CVE-2014-9032, CVE-2014-9033, CVE-2014-9034, CVE-2014-9035, CVE-2014-9036, CVE-2014-9037, CVE-2014-9038, CVE-2014-9039

BID: 71231, 71232, 71233, 71234, 71236, 71237, 71238

CWE: 20, 442, 629, 711, 712, 722, 725, 74, 750, 751, 79, 800, 801, 809, 811, 864, 900, 928, 931, 990