GLSA-201411-07 : Openswan: Denial of Service

Medium Nessus Plugin ID 79415


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201411-07 (Openswan: Denial of Service)

A NULL pointer dereference has been found in Openswan.
Impact :

A remote attacker could create a Denial of Service condition.
Workaround :

There is no known workaround at this time.


Gentoo has discontinued support for Openswan. We recommend that users unmerge Openswan:
# emerge --unmerge 'net-misc/openswan' NOTE: The Gentoo developer(s) maintaining Openswan have discontinued support at this time. It may be possible that a new Gentoo developer will update Openswan at a later date. Alternatives packages such as Libreswan and strongSwan are currently available in Gentoo Portage.

See Also

Plugin Details

Severity: Medium

ID: 79415

File Name: gentoo_GLSA-201411-07.nasl

Version: $Revision: 1.2 $

Type: local

Published: 2014/11/24

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:openswan, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/11/23

Reference Information

CVE: CVE-2013-6466

BID: 65629

GLSA: 201411-07