Mandriva Linux Security Advisory : php-smarty (MDVSA-2014:221)

High Nessus Plugin ID 79408


The remote Mandriva Linux host is missing one or more security updates.


An XSS vulnerability in the SmartyException class in Smarty (aka smarty-php) before 3.1.12 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors that trigger a Smarty exception (CVE-2012-4437).

Smarty before 3.1.21 allows remote attackers to bypass the secure mode restrictions and execute arbitrary PHP code as demonstrated by '<script language=php>' in a template (CVE-2014-8350).


Update the affected php-smarty and / or php-smarty-doc packages.

See Also

Plugin Details

Severity: High

ID: 79408

File Name: mandriva_MDVSA-2014-221.nasl

Version: $Revision: 1.5 $

Type: local

Published: 2014/11/24

Modified: 2015/01/09

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:php-smarty, p-cpe:/a:mandriva:linux:php-smarty-doc, cpe:/o:mandriva:business_server:1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/11/21

Reference Information

CVE: CVE-2012-4437, CVE-2014-8350

BID: 55506, 70708

MDVSA: 2014:221