PHP 5.6.x < 5.6.3 'donote' DoS

High Nessus Plugin ID 79248


The remote web server uses a version of PHP that is affected by a denial of service vulnerability.


According to its banner, the version of PHP 5.6.x installed on the remote host is prior to 5.6.3. It is, therefore, affected by an out-of-bounds read error in the function 'donote' within the file 'ext/fileinfo/libmagic/readelf.c' that could allow application crashes.

Note that Nessus has not attempted to exploit these issues but has instead relied only on the application's self-reported version number.


Upgrade to PHP version 5.6.3 or later.

See Also

Plugin Details

Severity: High

ID: 79248

File Name: php_5_6_3.nasl

Version: Revision: 1.1

Type: remote

Family: CGI abuses

Published: 2014/11/14

Updated: 2014/11/14

Dependencies: 48243

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/11/13

Vulnerability Publication Date: 2014/11/13

Reference Information

CVE: CVE-2014-3710

BID: 70807