PHP 5.6.x < 5.6.3 'donote' DoS

medium Nessus Plugin ID 79248
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server uses a version of PHP that is affected by a denial of service vulnerability.

Description

According to its banner, the version of PHP 5.6.x installed on the remote host is prior to 5.6.3. It is, therefore, affected by an out-of-bounds read error in the function 'donote' within the file 'ext/fileinfo/libmagic/readelf.c' that could allow application crashes.

Note that Nessus has not attempted to exploit these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to PHP version 5.6.3 or later.

See Also

http://php.net/ChangeLog-5.php#5.6.3

https://bugs.php.net/bug.php?id=68283

http://www.nessus.org/u?6f0615b4

Plugin Details

Severity: Medium

ID: 79248

File Name: php_5_6_3.nasl

Version: 1.3

Type: remote

Family: CGI abuses

Published: 11/14/2014

Updated: 1/19/2021

Dependencies: php_version.nasl

Risk Information

CVSS Score Source: CVE-2014-3710

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Ease: No known exploits are available

Patch Publication Date: 11/13/2014

Vulnerability Publication Date: 11/13/2014

Reference Information

CVE: CVE-2014-3710

BID: 70807