PHP 5.5.x < 5.5.19 'donote' DoS

medium Nessus Plugin ID 79247


The remote web server uses a version of PHP that is affected by a denial of service vulnerability.


According to its banner, the version of PHP 5.5.x installed on the remote host is prior to 5.5.19. It is, therefore, affected by an out-of-bounds read error in the function 'donote' within the file 'ext/fileinfo/libmagic/readelf.c' that could allow application crashes.

Note that Nessus has not attempted to exploit these issues but has instead relied only on the application's self-reported version number.


Upgrade to PHP version 5.5.19 or later.

See Also

Plugin Details

Severity: Medium

ID: 79247

File Name: php_5_5_19.nasl

Version: 1.7

Type: remote

Family: CGI abuses

Published: 11/14/2014

Updated: 4/11/2022

Risk Information

CVSS Score Source: CVE-2014-3710


Risk Factor: Low

Score: 3.6


Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Ease: No known exploits are available

Patch Publication Date: 11/13/2014

Vulnerability Publication Date: 11/13/2014

Reference Information

CVE: CVE-2014-3710

BID: 70807