CentOS 6 / 7 : libvncserver (CESA-2014:1826)

High Nessus Plugin ID 79188

Synopsis

The remote CentOS host is missing one or more security updates.

Description

Updated libvncserver packages that fix multiple security issues are now available for Red Hat Enterprise Linux 6 and 7.

Red Hat Product Security has rated this update as having Moderate security impact. Common Vulnerability Scoring System (CVSS) base scores, which give detailed severity ratings, are available for each vulnerability from the CVE links in the References section.

LibVNCServer is a library that allows for easy creation of VNC server or client functionality.

An integer overflow flaw, leading to a heap-based buffer overflow, was found in the way screen sizes were handled by LibVNCServer. A malicious VNC server could use this flaw to cause a client to crash or, potentially, execute arbitrary code in the client. (CVE-2014-6051)

A NULL pointer dereference flaw was found in LibVNCServer's framebuffer setup. A malicious VNC server could use this flaw to cause a VNC client to crash. (CVE-2014-6052)

A NULL pointer dereference flaw was found in the way LibVNCServer handled certain ClientCutText message. A remote attacker could use this flaw to crash the VNC server by sending a specially crafted ClientCutText message from a VNC client. (CVE-2014-6053)

A divide-by-zero flaw was found in the way LibVNCServer handled the scaling factor when it was set to '0'. A remote attacker could use this flaw to crash the VNC server using a malicious VNC client.
(CVE-2014-6054)

Two stack-based buffer overflow flaws were found in the way LibVNCServer handled file transfers. A remote attacker could use this flaw to crash the VNC server using a malicious VNC client.
(CVE-2014-6055)

Red Hat would like to thank oCERT for reporting these issues. oCERT acknowledges Nicolas Ruff as the original reporter.

All libvncserver users are advised to upgrade to these updated packages, which contain backported patches to correct these issues.
All running applications linked against libvncserver must be restarted for this update to take effect.

Solution

Update the affected libvncserver packages.

See Also

http://www.nessus.org/u?ad9df66e

http://www.nessus.org/u?7badfd9e

Plugin Details

Severity: High

ID: 79188

File Name: centos_RHSA-2014-1826.nasl

Version: 1.7

Type: local

Agent: unix

Published: 2014/11/12

Updated: 2019/10/02

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:centos:centos:libvncserver, p-cpe:/a:centos:centos:libvncserver-devel, cpe:/o:centos:centos:6, cpe:/o:centos:centos:7

Required KB Items: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/11/12

Vulnerability Publication Date: 2014/09/30

Reference Information

CVE: CVE-2014-6051, CVE-2014-6052, CVE-2014-6053, CVE-2014-6054, CVE-2014-6055

BID: 70091, 70092, 70093, 70094, 70096

RHSA: 2014:1826