VMware vCenter Converter 5.1.x < 5.1.2 / 5.5.x < 5.5.3 Multiple Vulnerabilities (VMSA-2014-0010) (Shellshock)

critical Nessus Plugin ID 79147
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host has an application installed that is affected by multiple vulnerabilities.

Description

The version of VMware vCenter Converter installed on the remote Windows host is 5.1.x prior to 5.1.2 or 5.5.x prior to 5.5.3. It is, therefore, affected by the following vulnerabilities :

- A command injection vulnerability exists in GNU Bash known as Shellshock, which is due to the processing of trailing strings after function definitions in the values of environment variables. This allows a remote attacker to execute arbitrary code via environment variable manipulation depending on the configuration of the system. While this host is not directly impacted by Shellshock, the standalone Converter application does deploy a Helper VM during Linux P2V conversions. This Helper VM contains a vulnerable version of Bash.
(CVE-2014-6271, CVE-2014-6277, CVE-2014-6278, CVE-2014-7169, CVE-2014-7186, CVE-2014-7187)

- A memory double-free error exists in 'd1_both.c' related to handling DTLS packets that allows denial of service attacks. (CVE-2014-3505)

- An unspecified error exists in 'd1_both.c' related to handling DTLS handshake messages that allows denial of service attacks due to large amounts of memory being consumed. (CVE-2014-3506)

- A memory leak error exists in 'd1_both.c' related to handling specially crafted DTLS packets that allows denial of service attacks. (CVE-2014-3507)

- A NULL pointer dereference error exists related to handling anonymous ECDH cipher suites and crafted handshake messages that allows denial of service attacks against clients. (CVE-2014-3510)

Solution

Upgrade to VMware vCenter Converter 5.1.2 / 5.5.3 or later.

See Also

https://www.vmware.com/security/advisories/VMSA-2014-0010.html

http://seclists.org/oss-sec/2014/q3/650

https://www.invisiblethreat.ca/post/shellshock/

Plugin Details

Severity: Critical

ID: 79147

File Name: vmware_vcenter_converter_2014-0010.nasl

Version: 1.17

Type: local

Agent: windows

Family: Windows

Published: 11/12/2014

Updated: 11/15/2018

Dependencies: vmware_vcenter_converter_installed.nbin

Risk Information

VPR

Risk Factor: Critical

Score: 9.8

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 8.7

Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:vmware:vcenter_converter

Required KB Items: installed_sw/VMware vCenter Converter

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 10/9/2014

Vulnerability Publication Date: 8/6/2014

Exploitable With

Core Impact

Metasploit (CUPS Filter Bash Environment Variable Code Injection (Shellshock))

Reference Information

CVE: CVE-2014-3505, CVE-2014-3506, CVE-2014-3507, CVE-2014-3510, CVE-2014-6271, CVE-2014-7169, CVE-2014-7186, CVE-2014-7187, CVE-2014-6277, CVE-2014-6278

BID: 69076, 69078, 69081, 69082, 70103, 70137, 70152, 70154, 70165, 70166

CERT: 252743

IAVA: 2014-A-0142

EDB-ID: 34765, 34766, 34777

VMSA: 2014-0010