RHEL 6 : Red Hat Storage 2.0 (RHSA-2013:1205)

Low Nessus Plugin ID 78970


The remote Red Hat host is missing one or more security updates.


Updated Red Hat Storage 2.0 packages that fix multiple security issues, various bugs, and add one enhancement are now available.

The Red Hat Security Response Team has rated this update as having low security impact. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available from the CVE link in the References section.

Red Hat Storage is a software only, scale-out storage solution that provides flexible and agile unstructured data storage for the enterprise.

Multiple insecure temporary file creation flaws were found in Red Hat Storage server. A local user on the Red Hat Storage server could use these flaws to cause arbitrary files to be overwritten as the root user via a symbolic link attack. (CVE-2013-4157)

These issues were discovered by Gowrishankar Rajaiyan of Red Hat and Kurt Seifried of the Red Hat Security Response Team.

This update also fixes the following bugs :

* Previously, rolling upgrades on a volume caused some processes to abort which led to a possible corruption of the volume. Yum update aborts with a message to stop the volume during an update. Now, with this update rolling upgrades is not supported and it is mandatory to stop the volume before any 'yum update'. (BZ#998649)

* Installing or upgrading the gluster-swift-plugin RPM overwrites /etc/swift configuration files. Hence, the customer configuration is overwritten, causing data unavailability. Now, the RPM installs or upgrades new configuration files with a non-conflicting extension and customer configuration files are not overwritten, maintaining data availability. (BZ #997940, BZ#1000423)

This update also adds the following enhancement :

* A new upgrade script has been added. When Red Hat Storage Server 2.1 is released, this script will help users upgrade and resubscribe their Red Hat Storage Server 2.0 Update 6 systems to Red Hat Storage Server 2.1. (BZ# 1002872)

All users of Red Hat Storage are advised to upgrade to these updated packages.


Update the affected packages.

See Also



Plugin Details

Severity: Low

ID: 78970

File Name: redhat-RHSA-2013-1205.nasl

Version: $Revision: 1.3 $

Type: local

Agent: unix

Published: 2014/11/08

Modified: 2017/01/05

Dependencies: 12634

Risk Information

Risk Factor: Low


Base Score: 3.6

Temporal Score: 3.1

Vector: CVSS2#AV:L/AC:L/Au:N/C:N/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:redhat:enterprise_linux:appliance-base, p-cpe:/a:redhat:enterprise_linux:gluster-swift-plugin, p-cpe:/a:redhat:enterprise_linux:glusterfs, p-cpe:/a:redhat:enterprise_linux:glusterfs-debuginfo, p-cpe:/a:redhat:enterprise_linux:glusterfs-devel, p-cpe:/a:redhat:enterprise_linux:glusterfs-fuse, p-cpe:/a:redhat:enterprise_linux:glusterfs-geo-replication, p-cpe:/a:redhat:enterprise_linux:glusterfs-rdma, p-cpe:/a:redhat:enterprise_linux:glusterfs-server, cpe:/o:redhat:enterprise_linux:6

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2013/09/04

Reference Information

CVE: CVE-2013-4157

BID: 62970

RHSA: 2013:1205