Debian DSA-3064-1 : php5 - security update

High Nessus Plugin ID 78861

Synopsis

The remote Debian host is missing a security-related update.

Description

Several vulnerabilities were found in PHP, a general-purpose scripting language commonly used for web application development. It has been decided to follow the stable 5.4.x releases for the Wheezy PHP packages. Consequently the vulnerabilities are addressed by upgrading PHP to a new upstream version 5.4.34, which includes additional bug fixes, new features and possibly incompatible changes. Please refer to the upstream changelog for more information :

http://php.net/ChangeLog-5.php#5.4.34

Solution

Upgrade the php5 packages.

For the stable distribution (wheezy), these problems have been fixed in version 5.4.34-0+deb7u1.

See Also

http://php.net/ChangeLog-5.php#5.4.34

https://packages.debian.org/source/wheezy/php5

https://www.debian.org/security/2014/dsa-3064

Plugin Details

Severity: High

ID: 78861

File Name: debian_DSA-3064.nasl

Version: 1.13

Type: local

Agent: unix

Published: 2014/11/05

Updated: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:php5, cpe:/o:debian:debian_linux:7.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/11/04

Reference Information

CVE: CVE-2013-7345, CVE-2014-3668, CVE-2014-3669, CVE-2014-3670

BID: 70611, 70665, 70666

DSA: 3064