Jenkins < 1.583 / 1.565.3 and Jenkins Enterprise 1.532.x / 1.554.x / 1.565.x < 1.532.10.1 / 1.554.10.1 / 1.565.3.1 Multiple Vulnerabilities

High Nessus Plugin ID 78859

Synopsis

The remote web server hosts a job scheduling and management system that is affected by multiple vulnerabilities.

Description

The remote web server hosts a version of Jenkins (open source) or CloudBees Jenkins Enterprise that is affected by multiple vulnerabilities :

- An error exists related to file upload processing that allows a remote attacker to overwrite arbitrary files.
(CVE-2013-2186)

- An input validation error exists related to the included 'ZeroClipboard' component that allows cross-site scripting attacks. (CVE-2014-1869)

- An error exists related to 'CLI handshake' handling that allows denial of service attacks. (CVE-2014-3661)

- An error exists related to handling login attempts using non-existent or incorrect account names that allows a remote attacker to enumerate application user names.
(CVE-2014-3662)

- An error exists related to handling users having 'Job/CONFIGURE' permissions that allows such users to perform actions meant only for 'Job/CREATE' permissions.
(CVE-2014-3663)

- An error exists related to handling users having 'Overall/READ' permissions that allows directory traversal attacks. (CVE-2014-3664)

- An error exists related to the 'CLI channel' that allows arbitrary code execution by a remote attacker on the Jenkins master. (CVE-2014-3666)

- An error exists related to handling users having 'Overall/READ' permissions that allows plugin source code to be disclosed. (CVE-2014-3667)

- An input validation error exists related to the 'Monitoring' plugin that allows cross-site scripting attacks. (CVE-2014-3678)

- An error exists related to the 'Monitoring' plugin that allows unauthorized access to sensitive information.
(CVE-2014-3679)

- An error exists related to handling users having 'Job/READ' permissions that allows such users to obtain default passwords belonging to parameterized jobs. (CVE-2014-3680)

- An unspecified input validation error allows cross-site scripting attacks. (CVE-2014-3681)

Solution

Upgrade to Jenkins 1.583 / 1.565.3 or Jenkins Enterprise 1.532.10.1 / 1.554.10.1 / 1.565.3.1 or later.

See Also

http://www.nessus.org/u?1236c16f

http://www.nessus.org/u?8f0783e9

Plugin Details

Severity: High

ID: 78859

File Name: jenkins_1_583.nasl

Version: 1.5

Type: remote

Family: CGI abuses

Published: 2014/11/04

Updated: 2019/11/25

Dependencies: 65054

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:cloudbees:jenkins, cpe:/a:jenkins-ci:monitoring_plugin

Required KB Items: www/Jenkins

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/09/26

Vulnerability Publication Date: 2014/09/26

Reference Information

CVE: CVE-2013-2186, CVE-2014-1869, CVE-2014-3661, CVE-2014-3662, CVE-2014-3663, CVE-2014-3664, CVE-2014-3666, CVE-2014-3667, CVE-2014-3678, CVE-2014-3679, CVE-2014-3680, CVE-2014-3681

BID: 63174, 65484

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990