Amazon Linux AMI : xerces-j2 (ALAS-2014-436)

High Nessus Plugin ID 78779

Synopsis

The remote Amazon Linux AMI host is missing a security update.

Description

A resource consumption issue was found in the way Xerces-J handled XML declarations. A remote attacker could use an XML document with a specially crafted declaration using a long pseudo-attribute name that, when parsed by an application using Xerces-J, would cause that application to use an excessive amount of CPU.

Solution

Run 'yum update xerces-j2' to update your system.

See Also

https://alas.aws.amazon.com/ALAS-2014-436.html

Plugin Details

Severity: High

ID: 78779

File Name: ala_ALAS-2014-436.nasl

Version: 1.3

Type: local

Agent: unix

Published: 2014/11/03

Updated: 2018/04/18

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:C

Vulnerability Information

CPE: p-cpe:/a:amazon:linux:xerces-j2, p-cpe:/a:amazon:linux:xerces-j2-demo, p-cpe:/a:amazon:linux:xerces-j2-javadoc-apis, p-cpe:/a:amazon:linux:xerces-j2-javadoc-impl, p-cpe:/a:amazon:linux:xerces-j2-javadoc-other, p-cpe:/a:amazon:linux:xerces-j2-javadoc-xni, p-cpe:/a:amazon:linux:xerces-j2-scripts, cpe:/o:amazon:linux

Required KB Items: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

Patch Publication Date: 2014/10/28

Reference Information

CVE: CVE-2013-4002

ALAS: 2014-436

RHSA: 2014:1319