RHEL 5 : php53 (RHSA-2014:1768)

High Nessus Plugin ID 78760


The remote Red Hat host is missing one or more security updates.


Updated php53 packages that fix multiple security issues are now available for Red Hat Enterprise Linux 5.

Red Hat Product Security has rated this update as having Important security impact. Common Vulnerability Scoring System (CVSS) base scores, which give detailed severity ratings, are available for each vulnerability from the CVE links in the References section.

PHP is an HTML-embedded scripting language commonly used with the Apache HTTP Server.

A buffer overflow flaw was found in the Exif extension. A specially crafted JPEG or TIFF file could cause a PHP application using the exif_thumbnail() function to crash or, possibly, execute arbitrary code with the privileges of the user running that PHP application.

An integer overflow flaw was found in the way custom objects were unserialized. Specially crafted input processed by the unserialize() function could cause a PHP application to crash. (CVE-2014-3669)

An out-of-bounds read flaw was found in the way the File Information (fileinfo) extension parsed Executable and Linkable Format (ELF) files. A remote attacker could use this flaw to crash a PHP application using fileinfo via a specially crafted ELF file.

An out of bounds read flaw was found in the way the xmlrpc extension parsed dates in the ISO 8601 format. A specially crafted XML-RPC request or response could possibly cause a PHP application to crash.

The CVE-2014-3710 issue was discovered by Francisco Alonso of Red Hat Product Security.

All php53 users are advised to upgrade to these updated packages, which contain backported patches to correct these issues. After installing the updated packages, the httpd daemon must be restarted for the update to take effect.


Update the affected packages.

See Also






Plugin Details

Severity: High

ID: 78760

File Name: redhat-RHSA-2014-1768.nasl

Version: $Revision: 1.14 $

Type: local

Agent: unix

Published: 2014/10/31

Modified: 2017/01/06

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:redhat:enterprise_linux:php53, p-cpe:/a:redhat:enterprise_linux:php53-bcmath, p-cpe:/a:redhat:enterprise_linux:php53-cli, p-cpe:/a:redhat:enterprise_linux:php53-common, p-cpe:/a:redhat:enterprise_linux:php53-dba, p-cpe:/a:redhat:enterprise_linux:php53-debuginfo, p-cpe:/a:redhat:enterprise_linux:php53-devel, p-cpe:/a:redhat:enterprise_linux:php53-gd, p-cpe:/a:redhat:enterprise_linux:php53-imap, p-cpe:/a:redhat:enterprise_linux:php53-intl, p-cpe:/a:redhat:enterprise_linux:php53-ldap, p-cpe:/a:redhat:enterprise_linux:php53-mbstring, p-cpe:/a:redhat:enterprise_linux:php53-mysql, p-cpe:/a:redhat:enterprise_linux:php53-odbc, p-cpe:/a:redhat:enterprise_linux:php53-pdo, p-cpe:/a:redhat:enterprise_linux:php53-pgsql, p-cpe:/a:redhat:enterprise_linux:php53-process, p-cpe:/a:redhat:enterprise_linux:php53-pspell, p-cpe:/a:redhat:enterprise_linux:php53-snmp, p-cpe:/a:redhat:enterprise_linux:php53-soap, p-cpe:/a:redhat:enterprise_linux:php53-xml, p-cpe:/a:redhat:enterprise_linux:php53-xmlrpc, cpe:/o:redhat:enterprise_linux:5

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/10/30

Reference Information

CVE: CVE-2014-3668, CVE-2014-3669, CVE-2014-3670, CVE-2014-3710

BID: 70611, 70665, 70666, 70807

OSVDB: 113421, 113422, 113423, 113614

RHSA: 2014:1768