Oracle Adaptive Access Manager Server Arbitrary Code Execution (October 2014 CPU)

High Nessus Plugin ID 78700


The remote host is affected by a remote code execution vulnerability.


The remote Oracle Adaptive Access Manager installation is missing a vendor supplied update that fixes a flaw in Apache Struts which allows remote attackers to execute arbitrary code.


Apply the appropriate patch according to the October 2014 Oracle Critical Patch Update advisory.

See Also

Plugin Details

Severity: High

ID: 78700

File Name: oracle_oaam_cpu_oct_2014.nasl

Version: $Revision: 1.8 $

Type: local

Family: Misc.

Published: 2014/10/28

Modified: 2016/12/07

Dependencies: 78699

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

Vulnerability Information

CPE: cpe:/a:oracle:fusion_middleware

Required KB Items: installed_sw/Oracle Adaptive Access Manager

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/10/14

Vulnerability Publication Date: 2014/10/14

Exploitable With

Metasploit (Apache Struts ClassLoader Manipulation Remote Code Execution)

Reference Information

CVE: CVE-2014-0114

BID: 67121

OSVDB: 106409