Mandriva Linux Security Advisory : mediawiki (MDVSA-2014:198)

Medium Nessus Plugin ID 78614


The remote Mandriva Linux host is missing one or more security updates.


Updated mediawiki packages fix security vulnerability :

MediaWiki before 1.23.4 is vulnerable to cross-site scripting due to JavaScript injection via CSS in uploaded SVG files (CVE-2014-7199).

MediaWiki before 1.23.5 is vulnerable to cross-site scripting due to JavaScript injection via user-specificed CSS in certain special pages (CVE-2014-7295).


Update the affected packages.

See Also

Plugin Details

Severity: Medium

ID: 78614

File Name: mandriva_MDVSA-2014-198.nasl

Version: $Revision: 1.1 $

Type: local

Published: 2014/10/22

Modified: 2014/10/22

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:mediawiki, p-cpe:/a:mandriva:linux:mediawiki-mysql, p-cpe:/a:mandriva:linux:mediawiki-pgsql, p-cpe:/a:mandriva:linux:mediawiki-sqlite, cpe:/o:mandriva:business_server:1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/10/21

Reference Information

CVE: CVE-2014-7199, CVE-2014-7295

BID: 70153, 70238

MDVSA: 2014:198