OpenSSL 1.0.0 < 1.0.1o Multiple Vulnerabilities (POODLE)

Medium Nessus Plugin ID 78553


The remote service is affected by multiple vulnerabilities.


According to its banner, the remote web server uses a version of OpenSSL 1.0.0 prior to 1.0.0o. The OpenSSL library is, therefore, affected by the following vulnerabilities :

- An error exists related to the way SSL 3.0 handles padding bytes when decrypting messages encrypted using block ciphers in cipher block chaining (CBC) mode. A man-in-the-middle attacker can decrypt a selected byte of a cipher text in as few as 256 tries if they are able to force a victim application to repeatedly send the same data over newly created SSL 3.0 connections. This is also known as the 'POODLE' issue. (CVE-2014-3566)

- An error exists related to session ticket handling that can allow denial of service attacks via memory leaks.

- An error exists related to the build configuration process and the 'no-ssl3' build option that allows servers and clients to process insecure SSL 3.0 handshake messages. (CVE-2014-3568)


Upgrade to OpenSSL 1.0.0o or later.

See Also

Plugin Details

Severity: Medium

ID: 78553

File Name: openssl_1_0_0o.nasl

Version: $Revision: 1.13 $

Type: remote

Family: Web Servers

Published: 2014/10/17

Modified: 2016/05/24

Dependencies: 57323

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: openssl/port

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/10/15

Vulnerability Publication Date: 2014/10/14

Reference Information

CVE: CVE-2014-3566, CVE-2014-3567, CVE-2014-3568

BID: 70574, 70585, 70586

OSVDB: 113251, 113374, 113377

CERT: 577193