PHP 5.6.x < 5.6.2 Multiple Vulnerabilities

High Nessus Plugin ID 78547

Synopsis

The remote web server uses a version of PHP that is affected by multiple vulnerabilities.

Description

According to its banner, the version of PHP 5.6.x installed on the remote host is prior to 5.6.2. It is, therefore, affected by the following vulnerabilities :

- A buffer overflow error exists in the function 'mkgmtime' that can allow application crashes or arbitrary code execution. (CVE-2014-3668)

- An integer overflow error exists in the function 'unserialize' that can allow denial of service attacks.
Note that this only affects 32-bit instances.
(CVE-2014-3669)

- A heap corruption error exists in the function 'exif_thumbnail' that can allow application crashes or arbitrary code execution. (CVE-2014-3670)

- An input-validation error exists in the cURL extension's file 'ext/curl/interface.c' and NULL option handling that can allow information disclosure. (Bug #68089)

Note that Nessus has not attempted to exploit these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to PHP version 5.6.2 or later.

See Also

http://www.php.net/ChangeLog-5.php#5.6.2

Plugin Details

Severity: High

ID: 78547

File Name: php_5_6_2.nasl

Version: 1.7

Type: remote

Family: CGI abuses

Published: 2014/10/17

Updated: 2018/07/24

Dependencies: 48243

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2014/10/16

Vulnerability Publication Date: 2014/10/16

Reference Information

CVE: CVE-2014-3668, CVE-2014-3669, CVE-2014-3670

BID: 70611, 70665, 70666