PHP 5.5.x < 5.5.18 Multiple Vulnerabilities

high Nessus Plugin ID 78546
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server uses a version of PHP that is affected by multiple vulnerabilities.

Description

According to its banner, the version of PHP 5.5.x installed on the remote host is prior to 5.5.18. It is, therefore, affected by the following vulnerabilities :

- A buffer overflow error exists in the function 'mkgmtime' that can allow application crashes or arbitrary code execution. (CVE-2014-3668)

- An integer overflow error exists in the function 'unserialize' that can allow denial of service attacks.
Note that this only affects 32-bit instances.
(CVE-2014-3669)

- A heap corruption error exists in the function 'exif_thumbnail' that can allow application crashes or arbitrary code execution. (CVE-2014-3670)

- An input-validation error exists in the cURL extension's file 'ext/curl/interface.c' and NULL option handling that can allow information disclosure. (Bug #68089)

Note that Nessus has not attempted to exploit these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to PHP version 5.5.18 or later.

See Also

http://www.php.net/ChangeLog-5.php#5.5.18

Plugin Details

Severity: High

ID: 78546

File Name: php_5_5_18.nasl

Version: 1.11

Type: remote

Family: CGI abuses

Published: 10/17/2014

Updated: 1/19/2021

Dependencies: php_version.nasl

Risk Information

CVSS Score Source: CVE-2014-3669

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Ease: No exploit is required

Patch Publication Date: 10/16/2014

Vulnerability Publication Date: 10/16/2014

Reference Information

CVE: CVE-2014-3668, CVE-2014-3669, CVE-2014-3670

BID: 70611, 70665, 70666