Oracle Identity Manager (October 2014 CPU

High Nessus Plugin ID 78542


The remote host has an application installed that is affected by multiple vulnerabilities.


The remote host is missing the October 2014 Critical Patch Update for Oracle Identity Manager. It is, therefore, affected by multiple vulnerabilities :

- The application is affected by a vulnerability in Apache Commons BeanUtils in which ClassLoader objects can be set via the class attribute of an ActionForm object. This can be used to manipulate the ClassLoader or execute arbitrary code. (CVE-2014-0114)

- The application is subject to a cross-site redirection attack because user-supplied input to the 'backUrl' parameter is not properly validated. (CVE-2014-2880)

- An unspecified vulnerability exists in the End User Self Service component. (CVE-2014-6487).


Apply the appropriate patch according to the October 2014 Oracle Critical Patch Update advisory.

See Also

Plugin Details

Severity: High

ID: 78542

File Name: oracle_identity_management_cpu_oct_2014.nasl

Version: $Revision: 1.9 $

Type: local

Family: Misc.

Published: 2014/10/17

Modified: 2016/12/07

Dependencies: 72042

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

Vulnerability Information

CPE: cpe:/a:oracle:identity_manager

Required KB Items: installed_sw/Oracle Identity Manager

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/10/14

Vulnerability Publication Date: 2014/04/03

Exploitable With

Metasploit (Apache Struts ClassLoader Manipulation Remote Code Execution)

Reference Information

CVE: CVE-2014-0114, CVE-2014-2880, CVE-2014-6487

BID: 66615, 67121, 70458

OSVDB: 105384, 106409, 113278

EDB-ID: 32670