VMware vCenter Server Appliance Bash Remote Code Execution (VMSA-2014-0010) (Shellshock)

Critical Nessus Plugin ID 78508


The remote host has a virtualization appliance installed that is affected by a command injection vulnerability.


The version of VMware vCenter Server Appliance installed on the remote host is 5.0 prior to Update 3b, 5.1 prior to Update 2b, or 5.5 prior to Update 2a. It therefore contains a version of bash that is affected by a command injection vulnerability via environment variable manipulation. Depending on the configuration of the system, an attacker could remotely execute arbitrary code.


Upgrade to VMware vCenter Server Appliance 5.0 Update 3b / 5.1 Update 2b / 5.5 Update 2a or later.

See Also




Plugin Details

Severity: Critical

ID: 78508

File Name: vmware_vcenter_server_appliance_vmsa-2014-0010.nasl

Version: $Revision: 1.15 $

Type: local

Family: Misc.

Published: 2014/10/16

Modified: 2017/04/25

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Temporal Score: 9

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:ND/RC:ND

Vulnerability Information

CPE: cpe:/a:vmware:vcenter_server_appliance

Required KB Items: Host/VMware vCenter Server Appliance/Version, Host/VMware vCenter Server Appliance/Build

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/04/25

Vulnerability Publication Date: 2014/09/24

Exploitable With

Core Impact

Metasploit (CUPS Filter Bash Environment Variable Code Injection (Shellshock))

Reference Information

CVE: CVE-2014-6271, CVE-2014-6277, CVE-2014-6278, CVE-2014-7169, CVE-2014-7186, CVE-2014-7187

BID: 70103, 70137, 70152, 70154, 70165, 70166

OSVDB: 112004, 112096, 112097, 112158, 112169

CERT: 252743

IAVA: 2014-A-0142

EDB-ID: 34765, 34766, 34777

VMSA: 2014-0010