MS KB3001237: Update for Vulnerabilities in Adobe Flash Player in Internet Explorer

High Nessus Plugin ID 78444


The remote host has an ActiveX control installed that is affected by multiple vulnerabilities.


The remote host is missing KB3001237. It is, therefore, affected by the following vulnerabilities :

- Multiple memory corruption issues due to improperly sanitized user-supplied input allow arbitrary code execution. (CVE-2014-0564, CVE-2014-0558)

- An integer overflow issue due to improperly sanitized user-supplied input that allows arbitrary code execution. (CVE-2014-0569)

- An arbitrary code execution vulnerability due to the handling of a dereferenced memory pointer.


Install Microsoft KB3001237.

See Also

Plugin Details

Severity: High

ID: 78444

File Name: smb_kb3001237.nasl

Version: $Revision: 1.12 $

Type: local

Agent: windows

Family: Windows

Published: 2014/10/15

Modified: 2017/08/30

Dependencies: 13855

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

Vulnerability Information

CPE: cpe:/o:microsoft:windows, cpe:/a:adobe:flash_player

Required KB Items: SMB/Registry/Enumerated, SMB/WindowsVersion

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/10/14

Vulnerability Publication Date: 2014/10/14

Exploitable With

Core Impact

Metasploit (Adobe Flash Player casi32 Integer Overflow)

Reference Information

CVE: CVE-2014-0558, CVE-2014-0564, CVE-2014-0569, CVE-2014-8439

BID: 70437, 70441, 70442, 71289

OSVDB: 113197, 113198, 113199, 115035

MSKB: 3001237