Adobe AIR <= AIR 15.0.0.249 Multiple Vulnerabilities (APSB14-22)

Critical Nessus Plugin ID 78440

Synopsis

The remote Windows host contains a version of Adobe AIR that is affected by multiple vulnerabilities.

Description

According to its version, the installation of Adobe AIR on the remote Windows host is equal or prior to 15.0.0.249. It is, therefore, affected by the following vulnerabilities :

- Multiple memory corruption issues due to improperly sanitized user-supplied input allow arbitrary code execution. (CVE-2014-0564, CVE-2014-0558)

- An integer overflow issue due to improperly sanitized user-supplied input that allows arbitrary code execution. (CVE-2014-0569)

- An arbitrary code execution vulnerability due to the handling of a dereferenced memory pointer.
(CVE-2014-8439)

Solution

Upgrade to Adobe AIR 15.0.0.293 or later.

See Also

https://helpx.adobe.com/security/products/flash-player/apsb14-22.html

Plugin Details

Severity: Critical

ID: 78440

File Name: adobe_air_apsb14-22.nasl

Version: 1.14

Type: local

Agent: windows

Family: Windows

Published: 2014/10/15

Updated: 2019/11/25

Dependencies: 32504

Risk Information

Risk Factor: Critical

CVSS Score Source: CVE-2014-8439

CVSS v2.0

Base Score: 10

Temporal Score: 8.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:air

Required KB Items: SMB/Adobe_AIR/Version, SMB/Adobe_AIR/Path

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/10/14

Vulnerability Publication Date: 2014/10/14

Exploitable With

Core Impact

Metasploit (Adobe Flash Player casi32 Integer Overflow)

Reference Information

CVE: CVE-2014-0558, CVE-2014-0564, CVE-2014-0569, CVE-2014-8439

BID: 70437, 70441, 70442, 71289