Bash Incomplete Fix Remote Code Execution Vulnerability (Shellshock)

Critical Nessus Plugin ID 78385


A system shell on the remote host is vulnerable to command injection.


The remote host is running a version of Bash that is vulnerable to command injection via environment variable manipulation. Depending on the configuration of the system, an attacker can remotely execute arbitrary code.


Apply the appropriate updates.

See Also

Plugin Details

Severity: Critical

ID: 78385

File Name: bash_cve_2014_7169.nasl

Version: 1.9

Type: remote

Agent: unix

Published: 2014/10/13

Modified: 2017/08/28

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Temporal Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:gnu:bash

Required KB Items: HostLevelChecks/proto

Exploit Available: true

Exploit Ease: Exploits are available

Exploited by Nessus: true

Patch Publication Date: 2014/09/24

Vulnerability Publication Date: 2014/09/24

Exploitable With

Metasploit (Pure-FTPd External Authentication Bash Environment Variable Code Injection)

Reference Information

CVE: CVE-2014-7169

BID: 70137

OSVDB: 112004

CERT: 252743

IAVA: 2014-A-0142

EDB-ID: 34765, 34766, 34777