Amazon Linux AMI : bash (ALAS-2014-419)

Critical Nessus Plugin ID 78362

Synopsis

The remote Amazon Linux AMI host is missing a security update.

Description

GNU Bash through 4.3 bash43-025 processes trailing strings after certain malformed function definitions in the values of environment variables, which allows remote attackers to write to files or possibly have unknown other impact via a crafted environment, as demonstrated by vectors involving the ForceCommand feature in OpenSSH sshd, the mod_cgi and mod_cgid modules in the Apache HTTP Server, scripts executed by unspecified DHCP clients, and other situations in which setting the environment occurs across a privilege boundary from Bash execution.

NOTE: this vulnerability exists because of an incomplete fix for CVE-2014-6271 and this bulletin is a follow-up to ALAS-2014-418.

It was discovered that the fixed-sized redir_stack could be forced to overflow in the Bash parser, resulting in memory corruption, and possibly leading to arbitrary code execution when evaluating untrusted input that would not otherwise be run as code.

An off-by-one error was discovered in the way Bash was handling deeply nested flow control constructs. Depending on the layout of the .bss segment, this could allow arbitrary execution of code that would not otherwise be executed by Bash.

Special notes :

Because of the exceptional nature of this security event, we have backfilled our 2014.03, 2013.09, and 2013.03 Amazon Linux AMI repositories with new bash packages that also fix both CVE-2014-7169 and CVE-2014-6271 .

For 2014.09 Amazon Linux AMIs, 'bash-4.1.2-15.21.amzn1' addresses both CVEs. Running 'yum clean all' followed by 'yum update bash' will install the fixed package.

For Amazon Linux AMIs 'locked' to the 2014.03 repositories, 'bash-4.1.2-15.21.amzn1' also addresses both CVEs. Running 'yum clean all' followed by 'yum update bash' will install the fixed package.

For Amazon Linux AMIs 'locked' to the 2013.09 or 2013.03 repositories, 'bash-4.1.2-15.18.22.amzn1' addresses both CVEs. Running 'yum clean all' followed by 'yum update bash' will install the fixed package.

For Amazon Linux AMIs 'locked' to the 2012.09, 2012.03, or 2011.09 repositories, run 'yum clean all' followed by 'yum
--releasever=2013.03 update bash' to install only the updated bash package.

If you are using a pre-2011.09 Amazon Linux AMI, then you are using a version of the Amazon Linux AMI that was part of our public beta, and we encourage you to move to a newer version of the Amazon Linux AMI as soon as possible.

Solution

Run 'yum update bash' to update your system. Note that you may need to run 'yum clean all' first.

See Also

https://aws.amazon.com/amazon-linux-ami/faqs/#lock

https://alas.aws.amazon.com/ALAS-2014-418.html

https://alas.aws.amazon.com/ALAS-2014-419.html

Plugin Details

Severity: Critical

ID: 78362

File Name: ala_ALAS-2014-419.nasl

Version: 1.8

Type: local

Agent: unix

Published: 2014/10/12

Updated: 2018/04/19

Dependencies: 12634

Risk Information

Risk Factor: Critical

CVSS v2.0

Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:amazon:linux:bash, p-cpe:/a:amazon:linux:bash-debuginfo, p-cpe:/a:amazon:linux:bash-doc, cpe:/o:amazon:linux

Required KB Items: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

Patch Publication Date: 2014/09/24

Reference Information

CVE: CVE-2014-7169, CVE-2014-7186, CVE-2014-7187

ALAS: 2014-419

IAVA: 2014-A-0142