Amazon Linux AMI : file (ALAS-2014-398)

Medium Nessus Plugin ID 78341

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 3.6

Synopsis

The remote Amazon Linux AMI host is missing a security update.

Description

Integer overflow in the cdf_read_property_info function in cdf.c in file through 5.19, as used in the Fileinfo component in PHP before 5.4.32 and 5.5.x before 5.5.16, allows remote attackers to cause a denial of service (application crash) via a crafted CDF file. NOTE:
this vulnerability exists because of an incomplete fix for CVE-2012-1571 .

Solution

Run 'yum update file' to update your system.

See Also

https://alas.aws.amazon.com/ALAS-2014-398.html

Plugin Details

Severity: Medium

ID: 78341

File Name: ala_ALAS-2014-398.nasl

Version: 1.3

Type: local

Agent: unix

Published: 2014/10/12

Updated: 2018/04/18

Dependencies: 12634

Risk Information

Risk Factor: Medium

VPR Score: 3.6

CVSS v2.0

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:amazon:linux:file, p-cpe:/a:amazon:linux:file-debuginfo, p-cpe:/a:amazon:linux:file-devel, p-cpe:/a:amazon:linux:file-libs, p-cpe:/a:amazon:linux:file-static, p-cpe:/a:amazon:linux:python-magic, cpe:/o:amazon:linux

Required KB Items: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

Patch Publication Date: 2014/09/03

Reference Information

CVE: CVE-2014-3587

ALAS: 2014-398