Amazon Linux AMI : libxml2 (ALAS-2014-340)

Medium Nessus Plugin ID 78283

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 3.6

Synopsis

The remote Amazon Linux AMI host is missing a security update.

Description

parser.c in libxml2 before 2.9.0, as used in Google Chrome before 28.0.1500.71 and other products, allows remote attackers to cause a denial of service (out-of-bounds read) via a document that ends abruptly, related to the lack of certain checks for the XML_PARSER_EOF state.

Solution

Run 'yum update libxml2' to update your system.

See Also

https://alas.aws.amazon.com/ALAS-2014-340.html

Plugin Details

Severity: Medium

ID: 78283

File Name: ala_ALAS-2014-340.nasl

Version: 1.7

Type: local

Agent: unix

Published: 2014/10/12

Updated: 2018/04/18

Dependencies: 12634

Risk Information

Risk Factor: Medium

VPR Score: 3.6

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:amazon:linux:libxml2, p-cpe:/a:amazon:linux:libxml2-debuginfo, p-cpe:/a:amazon:linux:libxml2-devel, p-cpe:/a:amazon:linux:libxml2-python, p-cpe:/a:amazon:linux:libxml2-static, cpe:/o:amazon:linux

Required KB Items: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

Patch Publication Date: 2014/05/21

Reference Information

CVE: CVE-2013-2877

ALAS: 2014-340